→→ Please check out our new WP Theme: Navian - Responsive Multi-Purpose WordPress Theme ←←
- In case you can't login to submit a ticket, please hard refresh the browser and try again.
If the problem persists, please submit your questions via THEMELOGI profile page instead.

- Regrading the plugin activation, please have a look at Bundled Plugin License information.
- If you couldn't import demo content, please see our FAQs page.
- We've updated the theme to be compatible with latest WordPress version,
please update your theme as in the article here

Tickets Tickets Navian Website Pages Blank

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #12494

    Since I updated PHP to 7.4 this morning the pges of my website are no longer displaying. I’m able to log into the WordPress dashboard however when I select visit site/shop I get a blank page.

    I know the pages are there as the content is there when I edit them.

    I’ve tried several different browsers and resetting the cache.

    The site is https://hyeconsultancy.procreative4web.com

    Can you help please?

    #12495
    This reply has been marked as private.
    #12499
    Danny
    Supporter

    Hi there,

    Thanks for writing in!

    I’ve just fixed the issue, please check your site again.

    The problem was caused by the ctype extension is disabled in your hosting, so the site couldn’t load. The LESSPHP library in TLG framework plugin use this function, but it’s the core PHP function, and it was disabled in your hosting.

    I’ve fixed it for you by modify the ctype function into another function in your site, but in this case, I recommend you to ask your hosting provider to enabled ctype extension so that my fix won’t be lost when you update the theme.

    You can see the similar error in other plugins such as the topics below:

    – siteorigin plugin: https://siteorigin.com/thread/fatal-error-call-to-undefined-function-ctype_digit/

    – jetpack plugin: https://wordpress.org/support/topic/php-7-2-9-not-working-with-jetpack-call-to-undefined-function-ctype_digit/

    In this case you should contact your hosting provider and ask them for a quick assistance with this via their Live Chat or Support Phone so they can enabled ctype extension for you. It’s your right to ask for these updates as you paid for their service and they usually react timely upon similar requests.

    P.S: I’ve fixed it in the lessc.inc.php file (change ctype to another similar function) in wp-content/plugins/tlg_framework/includes/lib/ folder.

    I hope this answers your questions, and if you need anything else, please let us know.

    Best regards,
    Danny

    #12535

    That’s great thanks Danny

    I will take it up with my hosting provider.

    Regards
    Ian

    #12552
    Danny
    Supporter

    You’re welcome!

    Have a great day!
    Danny

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.