→→ Please check out our new WP Theme: Navian - Responsive Multi-Purpose WordPress Theme ←←
- In case you can't login to submit a ticket, please hard refresh the browser and try again.
If the problem persists, please submit your questions via THEMELOGI profile page instead.

- Regrading the plugin activation, please have a look at Bundled Plugin License information.
- If you couldn't import demo content or you got the message "Failed to import", please see our FAQs page. Thank you :)
- We've updated the theme to be compatible with latest WordPress version, please update your theme as in the article here

Tickets Tickets Wanium Show Featured image of portfolio in all the portfolio pages

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1441

    I have hundreds of portfolio created, all have featured images in them. When I open page of that portfolio, I can’t find featured image in portfolio page of that image. I know that I can edit portfolio page of that image. But it is very difficult task to edit all the 100+ portfolio pages. Is there any shortcut so that all the portfolio pages start showing featured images in them. It is already show next and previous project. But it is not showing featured images.

    #1451
    Danny
    Supporter

    Hi pictureprefect,

    Thanks for writing in!

    The featured images in for portfolio header background image and in thumbnail of archive page only. If you want to show it in single portfolio page, please open up the single-portfolio.php file in themes/wanium/ folder, find the code below:

    <?php the_content(); wp_link_pages(); ?>

    … and change it into this:

    <?php 
    if ( has_post_thumbnail() ) {
        the_post_thumbnail( 'full', array( 'class' => 'mb16' ) );
    }
    the_content(); wp_link_pages(); 
    ?>

    Hope this helps,
    Danny

    #1456

    Thanks, now it started showing full image. But there is still an issue.
    Menu of the portfolio page is light and there is no cover in the portfolio pages. This is because, page title layout is set to “center” by default.
    Due to this, Menu items and logo is not visible.
    Can I set Page title layout to “center background large” for all the portfolio pages, so that Menu become visible?
    Or can I change the menu profile in all the portfolio pages to dark?

    #1468
    Danny
    Supporter

    Hi there,

    You can set the “Header Layout” to Standard if you don’t want to use image in header.

    Or you may want to have a look on our header setting in live demo:

    Best regards,
    Danny

    #1496

    Yes, I know this setting. But problem is that, I can’t set this setting in all the 200 portfolio images. I want set Page title layout to “center background large” for all the portfolio pages, so that Menu become visible in theme. Please visit below link to check what visibility issue I am facing in menu
    http://www.pictureprefect.in/portfolio/venue-2/
    http://www.pictureprefect.in/portfolio/venue/

    • This reply was modified 3 years, 6 months ago by pictureprefect. Reason: links were not visible
    #1502
    Danny
    Supporter

    Hi pictureprefect,

    To resolve this issue, please go to Dashboard > Appearances > Customize > Header, and set the default Header Layout to “Standard Header” as in the screenshot below:

    Hope this helps,
    Danny

    #1509

    After doing this, Menu is now visible in portfolio page, but transparent effect is gone from all other page.
    I want “Transparent Header No Topbar” as my default Header Layout. With this, I want Page title layout to “center background large” for all the portfolio pages. Please provide me the code fix.
    If above feature is not possible, please provide me the details, that how can I unable “Standard Header No Topbar – Header Layout” only for porfolio pages (around 200)

    #1526
    Danny
    Supporter

    Hi pictureprefect,

    Currently there is no such an option like this in the theme. Our theme only comes with 2 options:

    1. Global option: in Appearances > Customize
    2. Individual Page/Post option: at bottom of each page/post editor page.

    And the Individual option will override Global option.

    So if you want to use “Transparent Header No Topbar” as your default “Header Layout”, you’ll need to set your individual portfolio Header Layout as “Standard Header No Topbar”.

    But this could also be done with custom code, you can open up the header.php file in themes/wanium folder, find the code below:

    <?php get_template_part( 'templates/header/layout', wanium_get_header_layout() ); ?>

    .. and change it into this:

    <?php  
    global $post;
    $post_type 	= get_post_type();
    if( 'portfolio' == $post_type ) {
    	get_template_part( 'templates/header/layout', 'standard-no-top' );
    } else {
    	get_template_part( 'templates/header/layout', wanium_get_header_layout() );
    }
    ?>

    Hope this helps,
    Danny

    #1536

    thanks for reply.
    1 last thing I want to ask about this. Is it possible to show featured image of portfolio page as “center background large” on all the portfolio pages. It is very difficult task to set Page title layout to “center background large” for all the portfolio pages.
    Is it possible some how using code change or something?

    #1540
    Danny
    Supporter

    Hi pictureprefect,

    To resolve this issue, please open up the single-portfolio.php file in themes/wanium folder, find the code below:

    'layout' => get_post_meta( $post->ID, '_tlg_page_title_layout', true ),

    .. and change it into this:

    'layout' => 'center-bg-large',

    Hope this helps,
    Danny

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.