In case you can't login to submit a ticket, please hard refresh the browser and try to login again.
If the problem persists, please send us a message to email [email protected] so we can help you out.
To update the theme or plugins, please have a look on the article here: Theme & Plugin Updates. Also, if you can't import the demo content or the site is blank, please see our FAQs page for the solutions. Thank you :)

Home Tickets Roneous Portfolio URL Structure

This topic contains 23 replies, has 2 voices, and was last updated by  speech_free 10 months, 2 weeks ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #322

    Hello Danny,

    Currently I have a page that I created. The url looks like this:

    Web Site Γ‡evirisi

    On this page, I am showing the portfolio items with the desired portfolio category which is “web site cevirisi”, but the url of the item looks like this:
    http://webkazani.com/blog/portfolio/bakin-tarim/ (I have no idea why /blog is there)

    So, what I would like to do is when the portfolio item is clicked, it should go to the following url:
    http://webkazani.com/referanslar/web-site-cevirisi/bakin-tarim

    Breadcrumbs should follow the same pattern of course. πŸ™‚

    Is this even possible without so much headache?

    Thank you very much.

    #338
    This reply has been marked as private.
    #376

    Danny
    Supporter

    Hi speech_free!

    Since you to disabled the site, so I can’t access it, but seems that you are using a Post for portfolio. All the portfolio items are managed in Dashboard > Portfolio.

    – If the content comes from Dashboard > Pages, the URL will look like: yousite.com/pages/item-name (eg: http://demo.themelogi.com/roneous/pages/1-about-us/)
    – If the content comes from Dashboard > Posts, the URL will look like: yousite.com/blog/item-name (eg: http://demo.themelogi.com/roneous/2015/10/29/post-image-content/ – you can change the URL in Dashboard > Settings > Permalinks (we are using “Day and name” option in our live demo))
    – If the content comes from Dashboard > Portfolio, the URL will look like: yousite.com/portfolio/item-name (eg: http://demo.themelogi.com/roneous/portfolio/default-project/)
    – If the content comes from Dashboard > Products, the URL will look like: yousite.com/product/item-name (eg: http://demo.themelogi.com/roneous/product/camera-classic/)

    Although WordPress it’s easy to use and flexible enough but it’s need time to manage and to master. Hope one day you will back to WordPress and we are always here to help you πŸ™‚

    Best regards,
    Danny

    • This reply was modified 10 months, 3 weeks ago by  Danny.
    #409

    I decided to work locally first. Once I mastered, I will go live. :))

    Thanks for the help!

    #410

    Can you tell me how to do the following. My breadcrumb looks like this right now for the blog posts.

    Home > Blog > Blog Post Name

    When I click the Blog, I don’t get to the mysite.com/blog page

    I did not set the blog page as posts page under reading settings. That’s probably why. I know I need to edit helpers.php file but I don’t know how to do.

    #411
    This reply has been marked as private.
    #412

    Danny
    Supporter

    Hi speech_free,

    Thanks for your explanation πŸ™‚ We are glad to see that you sorted it out.

    And yes, you will need to modify one more file named “tlg_helper.php” in wp-content/plugins/tlg_framework/includes folder. There is a function named “tlg_framework_breadcrumbs” that works same as your modification above, you can find it around line 181 – 221.

    Hope this helps,
    Danny

    #416

    Thank you. I will do it. It is easy.

    One more thing about the breadcrumbs. Since I did not set the blog page as posts page under reading settings, I have another page showing blog posts. So, my post urls look like this:

    mysite.com/post-name

    How can I change it to mysite.com/blog/post-name

    Thank you very much.

    #417

    Danny
    Supporter

    Hi speech_free,

    To add ‘blog’ in your blog post URL, please go to Dashboard > Settings > Permalinks, and set the structure link as below:

    Best regards,
    Danny

    #420
    This reply has been marked as private.
    #421

    Danny
    Supporter

    Our themes are fully translation ready! The translation files .pot are located in languages folder in the theme package. We’ve included English as a default.

    To translate the theme, please follow these steps:

    1. Download and install POEdit
    2. Open the .pot file of the theme (inside languages folder) in Poedit and create new translation.
    3. Save your translations in a .po file (for example: fr_FR.po).
    4. Check the WordPress Codex language to give your file the right name.
    5. Edit the new .po file using POEdit
    6. PoEdit will automatically compile a .mo file for you when you save your work on the existing .po file.
    7. Change the language in the admin settings screen. Settings > General > Site Language.

    In case you want to build multilingual site, you can have a look on WPML plugin at https://wpml.org/

    Hope this helps,
    Danny

    #423

    I did this as described, but they were still not translated. I will give it a try again.

    #426

    Danny
    Supporter

    Hi speech_free,

    Thanks for your info!

    In case you need a more details tutorial, you may want to have a look at this article: https://premium.wpmudev.org/blog/how-to-translate-a-wordpress-theme

    Hope this helps,
    Danny

    #431

    Thank you for the article. For now, I will leave it for later.

    If you remember, I wanted to add blog in my blog post url, and I did as you suggested above. That works fine for blog posts.

    Now, I created a new portfolio item, and the url of the item looks like this.

    mysite.com/blog/portfolio/the-item-name

    Instead, it should look like this.

    mysite.com/portfolio/web-tasarim (a page that I want to show where the items are listed)/the-item-name

    I am sure I will have some other questions with breadcrumbs and this portfolio setup. So, I am just explaining my site structure.

    mysite.com/portfolio/web-tasarim/item-name (when you click web-tasarim, it should go to web-tasarim page where the items are listed)
    mysite.com/portfolio/web-site-cevirisi/item-name (when you click web-site-cevirisi, it should go to web-site-cevirisi page where the items are listed)

    Hope it helps you to give me better support. I am not in a hurry. So, don’t worry. πŸ™‚

    Thank you very much.

    #433

    Ok. Just nevermind the above. I just want the following.

    I created referanslar page where I have two columns showing web-tasarim and web-site-cevirisi.

    I also created web-tasarim page where I use portfolio listing element from the theme and selecting only web-tasarim category. So, there are only web-tasarim items are listed. Until here, everything works fine.

    If the portfolio item is web-tasarim, the url should look like this:

    mysite.com/referanslar/web-tasarim/item-name

    If the portfolio item is web-site-cevirisi, the url should look like this:

    mysite.com/referanslar/web-site-cevirisi/item-name

    Currently, the portfolio item (web-tasarim) looks like this:

    mysite.com/blog/portfolio/item-name

    Now, this is a better explanation I hope. πŸ™‚

    #437

    Danny
    Supporter

    Hi speech_free,

    Thanks for your explanation πŸ™‚ To resolve this issue, please follow the steps here:

    1. Go to Dashboard > Plugins > Add New, search for “WP Permastructure”, and install this plugin: https://wordpress.org/plugins/wp-permastructure/

    2. Go to Dashboard > Settings > Permalinks, and set the “Portfolio permalink structure” to “/referanslar/%portfolio_category%/%postname%”, as you can see the screenshot here:

    Hope this helps,
    Danny

    #445

    So, here is my understanding.

    I created a page called web-tasarim and the url is mysite.com/referanslar/web-tasarim
    I also created a category under portfolio which is web-tasarim

    With your suggestion, the url will be mysite.com/referanslar/web-tasarim (portfolio_category)

    So, the page I created with the name web-tasarim is not necessary?

    Will I be able to edit the portfolio category page with the visual composer? I don’t think so. πŸ™‚

    We are almost getting there. :)) I will try this tonight and let you guys know.

    Thanks!

    #448

    Danny
    Supporter

    Hi there!

    Yes, I think creating the page called web-tasarim is not necessary since you’ve already got the portfolio category.

    BTW, you can also edit the portfolio category listing layout in Appearances > Customize > Portfolio.

    Best regards,
    Danny

    #449

    Let me try first tonight, and I will get back to you. Don’t worry. πŸ˜€

    #452
    This reply has been marked as private.
    #462

    Danny
    Supporter

    Hi there,

    Thanks for the screenshot!

    To add portfolio category to the breadcrumb, please follow the steps here:

    1. Open up the helpers.php in themes/roneous/inc folder, find the “roneous_breadcrumbs” function, and right after this line:

    } elseif( is_post_type_archive('product') || is_archive() ) {
        // nothing
    } else {
       $breadcrumb .= '<li class="active">' . esc_html( get_the_title( $post->ID ) ) . '</li>';
    }

    … please change to this:

    } elseif( is_post_type_archive('product') || is_archive() ) {
    	// nothing
    } else {
    	if(is_singular('portfolio')) {
    		$breadcrumb .= get_the_term_list($post->ID, 'portfolio_category', '<li>', '&nbsp;/&nbsp;&nbsp;', '</li>');
    	}
    	$breadcrumb .= '<li class="active">' . esc_html( get_the_title( $post->ID ) ) . '</li>';
    }

    2. Open up the tlg_helper.php in tlg_framework/includes folder, find the “tlg_framework_breadcrumbs” function and do the same as above.

    3. Go to Appearance > Customize > Fonts & CSS, and add the code below in Custom CSS field:

    .breadcrumb-style li a, .breadcrumb-style li {background: transparent;border: none;padding: 0;margin: 0;}

    Hope this helps,
    Danny

    #467

    This is what I have got so far. πŸ™‚ I know I am too much trouble, but that’s why I gave up in the first place. Hope you don’t mind.

    Here is the screenshot.

    http://arnedental.com/test/portfolio-url-structure-2.png

    When I click the Web Tasarim in breadcrumbs, this is the page I get:

    http://arnedental.com/test/portfolio-url-structure-3.png

    This is the page you suggested to edit the portfolio category listing layout in Appearances > Customize > Portfolio.

    I am frustrated, hope you are not. πŸ™

    #478

    Danny
    Supporter

    Hi speech_free,

    This is the default portfolio archive page, you can try to set you background header image and portfolio header layout in Appearances > Customize > Portfolio.

    As you know, there’s no easy way to determine which portfolio page is the right page when one category is assigned to several portfolio pages. Therefore I will test the new breadcrumb and maybe implement it later on…

    Thanks for your understanding!
    Danny

    #481

    That’s okay. Thank you for taking in consideration. πŸ™‚

Viewing 24 posts - 1 through 24 (of 24 total)

The topic ‘Portfolio URL Structure’ is closed to new replies.