→→ Please check out our new WP Theme: Navian - Responsive Multi-Purpose WordPress Theme ←←
- In case you can't login to submit a ticket, please hard refresh the browser and try again.
If the problem persists, please submit your questions via THEMELOGI profile page instead.
- To update the theme or plugins, please have a look at Theme & Plugin Updates, and here is the Bundled Plugin License information.
- If you couldn't import demo content or you got the message "Failed to import", please see our FAQs page. Thank you :)

Tickets Tickets Navian One Page scroll

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11034

    Hello,

    I’m using the template to do a landing page. I have a top menu that is going to the different sections on the page, the problem is that after the scroll, the end position is not correct because some of the content is getting cut.

    Please find attached a video –> https://www.dropbox.com/s/6wgm1tk1by7j3ed/Test.mp4?dl=0

    It’s possible to change that setting in order to show the correct position?

    Thanks.

    #11041
    Danny
    Supporter

    Hi there,

    Thanks for writing in!

    To resolve this issue, please open up the scripts.js file in themes/navian/assets/js folder, find the code below (around line 276) :

    jQuery('a[href*="#"]').smoothScroll({ speed: 800 });

    … and change it into this (you can modify the offset pixel number as you wish) :

    jQuery('a[href^="#"]').smoothScroll({ offset: -50, speed: 800 });

    P.S: Please refresh the browser so the change in script can take effect.

    Hope this helps,
    Danny

    #11049

    Solved.

    Thanks a lot!

    #11054

    Hello Danny,

    A question, the code fixed the problem on the menu but on the button I have on the slider it’s still not working, any idea?

    Please see video here–> https://www.dropbox.com/s/ow5jt6g9basxlf4/Recording.mp4?dl=0

    Thanks in advance.

    #11059
    Danny
    Supporter

    Hi there,

    Thanks for your screencast video!

    About this issue, please share us your site URL and the admin account of your site via private reply or via the contact form at https://themeforest.net/user/themelogi so we can investigate your case and help you out. Also, please point to specific page where we can see the problem.

    Looking forward for your response!

    Best regards,
    Danny

    #11060
    This reply has been marked as private.
    #11075
    Danny
    Supporter

    Hi there,

    Thanks for your info!

    I’ve just fixed it using the code below:

    jQuery('.menu a[href*="#"]').smoothScroll({ offset: -70, speed: 800 });
    jQuery('.tlg-page-wrapper a[href*="#"]').not('.comment-reply-link,#cancel-comment-reply-link').smoothScroll({ offset: -150, speed: 800 });

    Could you please check again. Also, please refresh the browser so the change in script can take effect.

    Best regards,
    Danny

    #11081

    This is awesome.

    Thanks a lot Danny!

    #11084
    Danny
    Supporter

    Hi! You’re welcome. I’m always happy to help 🙂

    Please feel free to let me know about any other doubt you could have.

    Also, if you like our theme and the support, please consider to leave us a 5-star review rating for the theme via ThemeForest > Downloads section. It helps us a lot!

    Best regards,
    Danny

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.