In case you can't login to submit a ticket, please hard refresh the browser and try to login again.
If the problem persists, please send us a message to email [email protected] so we can help you out.
To update the theme or plugins, please have a look on the article here: Theme & Plugin Updates. Also, if you can't import the demo content or the site is blank, please see our FAQs page for the solutions. Thank you :)

Tickets Tickets Roneous huge problem with SEO & site indexing

This topic contains 18 replies, has 3 voices, and was last updated by  Danny 2 months, 1 week ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #7319

    Hi
    I have created a 8 page site for a client {Removed URL}
    My seo software ( serpstat) shows some 393 pages indexed most of which are dead 404 links although all the demo pages on the backend of wordpress have been removed .
    some of the pages indexed like {Removed URL} is somehow linked to the home page of the site.
    this is killing any work we are doing on the site with regards to seo
    please,this is urgent

    • This topic was modified 2 months, 3 weeks ago by  Danny. Reason: Remove URL info
    #7322

    Danny
    Supporter

    Hi there,

    Thanks for writing in!

    The problem was caused by you’ve imported the demo data into your site, and Google indexed it, so in this case, you just need to wait a little more time so that Google can re-index your site with your actual 8 pages site.

    Also, you may want to have a look at the articles here for more details: https://stackoverflow.com/a/15278642 or https://searchenginewatch.com/2018/04/20/how-to-force-google-to-recrawl-your-website/

    Hope this helps,
    Danny

    #7324

    Hi
    So,when you say that I have imported the demo data into my site,where am I supposed to have imported the demo into?

    #7328

    Danny
    Supporter

    Hi there,

    Thanks for your info!

    Actually, all other themes in the market work on the same way (import the sample demo data). If you don’t want to be indexed by Google when you imported the demo data, you can prevent Google indexing as in the article here: https://stackoverflow.com/questions/390368/stop-google-from-indexing then when you’re done, you can remove that file.

    Or you can set your site as in Coming Soon mode with a 3rd praty plugin such as https://wordpress.org/plugins/coming-soon/, so that Google can’t see any pages in your site, just the Coming Soon page. And when you’re done, you can turn off the Coming Soon mode.

    Or you can work on localhost in your computer first, then move it to the live site when you’re done.

    Hope this helps,
    Danny

    #7333
    This reply has been marked as private.
    #7336

    Danny
    Supporter

    Hi there,

    It’s ok, I’ve removed your URL info.

    To activate the WPBakery for the posts, please have a look at our FAQs page here (in Question 10, you can check into “post”): http://www.themelogi.com/tickets/topic/faq/

    Also, please make sure you’ve set the “Auto activate Visual Composer for Post?” option to “No” in Appearances > Customize > System.

    Hope this helps,
    Danny

    #7337

    Many thanks for that Danny,much appreciated
    Can you please let me have the line of code in the theme that I would need to remove in order to remove author & date from my blog.
    Thanks

    #7340

    Danny
    Supporter

    Hi! You’re welcome 🙂

    To remove the those info in a single post, please go to your Dashboard > Appearances > Customize > Blog, and set the ‘Enable Author Info?’ option to ‘No’.

    Hope this helps,
    Danny

    #7355
    This reply has been marked as private.
    #7357

    Danny
    Supporter

    Hi there,

    Thanks for our info!

    About this issue, please have a look at the article here for solutions: https://www.wpbeginner.com/wp-tutorials/how-to-fix-503-service-unavailable-error-in-wordpress/

    Normally, the problem was caused by your host has PHP configuration limits that are set too low to complete the process. Please ask your hosting provider and ask them to increase those limits to a minimum as follows:

    max_execution_time = 900
    max_input_time 600
    memory_limit = 256M
    post_max_size = 64M
    upload_max_filesize = 64M
    max_input_vars = 5000
    allow_url_fopen on

    And change PHP version to 7.0+ as in the article here: https://wordpress.org/about/requirements/

    In this case you should contact your hosting provider and ask them for a quick assistance with this via their Live Chat or Support Phone. It’s your right to ask for these updates as you paid for their service and they usually react timely upon similar requests.

    For the details of the solution, please have a look on the topic http://www.themelogi.com/tickets/topic/tlg-framework-crash/#post-177

    Please let me know if this work for you or not.

    Best regards,
    Danny

    #7364

    this is what I got back from hosting support:

    03/01/2019 (05:16)
    Hello Michael,

    Sorry for the inconvenience you are facing.

    As per checking the error logs I could see that the website is not compatible with the PHP 7 version.

    Following are the error logs reported for the website when it’s on PHP 7:

    01-Mar-2019 13:09:37 UTC] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/architecteco/public_html/wp-includes/wp-db.php:1645
    Stack trace:
    #0 /home/architecteco/public_html/wp-includes/wp-db.php(639): wpdb->db_connect()
    #1 /home/architecteco/public_html/wp-includes/load.php(435): wpdb->__construct(‘architecteco_wp…’, ‘p5d]2Hn1[S’, ‘architecteco_wp…’, ‘localhost’)
    #2 /home/architecteco/public_html/wp-settings.php(109): require_wp_db()
    #3 /home/architecteco/public_html/wp-config.php(89): require_once(‘/home/architect…’)
    #4 /home/architecteco/public_html/wp-load.php(37): require_once(‘/home/architect…’)
    #5 /home/architecteco/public_html/wp-blog-header.php(13): require_once(‘/home/architect…’)
    #6 /home/architecteco/public_html/index.php(17): require(‘/home/architect…’)
    #7 {main}
    thrown in /home/architecteco/public_html/wp-includes/wp-db.php on line 1645
    So I have changed the PHP version to 5.6 and could see that the website is working fine. You can check the compatibility of this website with your developer.

    If there is anything else that we can be assistance with or you have any other queries please feel free to contact us at any time.

    Regards,

    #7367

    Danny
    Supporter

    Hi there,

    Normally WP version 5.x version should work fine with PHP 7, what version of WP you installed on your site?

    Also, Have they already improved the PHP configuration limits as below ?

    max_execution_time = 900
    max_input_time 600
    memory_limit = 256M
    post_max_size = 64M
    upload_max_filesize = 64M
    max_input_vars = 5000
    allow_url_fopen on

    And what about the 503 error message, it’s gone or not ? Could you please share us the screenshot of those 503 error message ? Maybe it’s some cached pages by google crawl ? And now, when you delete those pages, you should wait a little more time so Google can re-crawl your site and update your latest pages.

    Best regards,
    Danny

    #7369
    This reply has been marked as private.
    #7370

    when I set PHP to 7 or above,the site breaks down and generates 500 error codes

    #7372

    Danny
    Supporter

    Hi there,

    Thanks for your info!

    About this issue, I recommend you to ask a SEO expert who can help you out better. Since the theme has nothing to do with 503 error, but just importing the sample data to post/page to database when you choose to import it.

    You can read more about 503 error here: https://www.itpro.co.uk/web-browser/30394/what-is-http-error-503-and-how-do-you-fix-it

    I’ve visited all the page in your site without the problems, so I guess you can ignore those 503 errors and focus on build the best content in the site. It’s only the problem if user can’t access it. Also, I believe it’s not the theme problem, I recommend you to switch to another theme to test it.

    About the PHP 7.x, it may caused by the plugins, have you try to deactivate all the plugins? or try to switch to another theme to see if the problem was caused by the theme or not.

    As you can see in the error log below. It’s from the WordPress core, it’s not related with the theme itself:

    01-Mar-2019 13:09:37 UTC] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/architecteco/public_html/wp-includes/wp-db.php:1645
    Stack trace:
    #0 /home/architecteco/public_html/wp-includes/wp-db.php(639): wpdb->db_connect()
    #1 /home/architecteco/public_html/wp-includes/load.php(435): wpdb->__construct(‘architecteco_wp…’, ‘p5d]2Hn1[S’, ‘architecteco_wp…’, ‘localhost’)
    #2 /home/architecteco/public_html/wp-settings.php(109): require_wp_db()
    #3 /home/architecteco/public_html/wp-config.php(89): require_once(‘/home/architect…’)
    #4 /home/architecteco/public_html/wp-load.php(37): require_once(‘/home/architect…’)
    #5 /home/architecteco/public_html/wp-blog-header.php(13): require_once(‘/home/architect…’)
    #6 /home/architecteco/public_html/index.php(17): require(‘/home/architect…’)
    #7 {main}
    thrown in /home/architecteco/public_html/wp-includes/wp-db.php on line 1645

    It’s similar to the error here: https://stackoverflow.com/questions/44841823/wordpress-fatal-error-uncaught-error-call-to-undefined-function-mysql-connect

    So you may want to try the solution in there to make it compatible with PHP 7.

    Best regards,
    Danny

    #7402

    Hi Danny
    The server hosting this site is not too bad.I can set all the PHP and configure most of the settings
    the problem is that the theme itself only runs on PHP 5.6
    10 Pages
    WordPress 5.1 running Roneous theme.

    Running PHP version: 5.6.40
    so when I set PHP 7 or higher,the site just breaks down.
    Are you guys planning to update to a more recent PHP version anytime soon or perhaps suggest a different solution?
    I can get some developers to upgrade the theme to 7 or higher but that for me defeats the objective of getting a cheaper theme to start with
    anyway,look forward to hearing from you
    Many thanks

    #7408

    Danny
    Supporter

    Hi there,

    Thanks for your info!

    Actually the theme works for more than 3800 customers, and I never heard about PHP 7 compatible issue with the theme. But I’ll check it, and keep updating the theme.

    Have you tried to deactivate all plugins and try again. If you got error, could you please share us a screenshot of that error? Also, Have you tried to switch to another theme, or reinstall WordPress 5.1 to see if the problem is gone or not.

    Best regards,
    Danny

    #7418

    A 503 Service Unavailable Error is an HTTP response status code indicating that your web server operates properly, but it can’t temporarily handle the request at the moment. This error happen for a wide variety of reasons. Normally, this error can be due to a temporary overloading or maintenance being performed on the server and it is resolved after a period of time or once another thread has been released by web-server application.

    How to fix HTTP 503 errors

    • Reload (Refresh) the page
    • Restart Your Devices
    • Scan for Malware
    • Clear Temporary Files
    • Visiting the website later
    • Contact server admin
    #7423

    Danny
    Supporter

    Hi there,

    Thanks for your info!

    The theme is fully compatible with PHP 7, just make sure you’ve installed a fresh WordPress latest version (because the error log in your previous message is about WordPress core, but not the theme). If the problem persists, believe the problem is Server-Side. I recommend you to ask the hosting provider about this issue to increase the PHP configuration limits. You may want to have a look at some article about it to get the solutions such as: https://airbrake.io/blog/http-errors/503-service-unavailable or https://www.keycdn.com/support/503-http-error

    Best regards,
    Danny

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.