In case you can't login to submit a ticket, please hard refresh the browser and try to login again.
If the problem persists, please send us a message via THEMELOGI profile page so we can help you out.
To update the theme or plugins, please have a look on the article here: Theme & Plugin Updates. Also, if you can't import the demo content or the site is blank, please see our FAQs page for the solutions. Thank you :)

Tickets Tickets Roneous Change Home link

This topic contains 6 replies, has 2 voices, and was last updated by  Danny 2 years, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #114

    Hi,
    This is not a bug, of course, but could you tell me how can I:

    Change the Home link in the breadcrumbs from blog.indielocalization.com to indielocalization.com?

    Screenshot: http://infinit.io/_/3icwCD4

    Currently, Roneus is installed in a WP network… The domain is blog.indielocalization.com (this is a subdomain of indielocalization.com). That’s why the home link is pointing to blog.indielocalization.com.

    I’d like it to point to indielocalization.com.

    Could you tell me which file in the database I should edit, and what I should write?

    If not possible, how can I turn off the breadcrumbs? I don’t see such options in the admin panel.

    Thanks a lot,
    Artem

    #116

    Danny
    Supporter

    Hi Artem,

    – Please follow the steps here to change the home link in breadcrumbs:

    Step 1. Open up the “helpers.php” file in themes/roneous/inc folder.

    And change the line 391 into this:

    $home = '<li><a href="http://indielocalization.com/" class="home-link" rel="home">' . esc_html__( 'Home', 'roneous' ) . '</a></li>';

    Step 2. Open up the “tlg_helpers.php” file in plugins/tlg_framework/includes folder.

    And change the line 391 into this:

    $home = '<li><a href="http://indielocalization.com/" class="home-link" rel="home">' . esc_html__( 'Home', 'tlg_framework' ) . '</a></li>';

    – If you want to turn off breadcrumbs, just follow the steps below:

    Step 1. Open up the “customizer.php” file in themes/roneous/inc folder, and change the line 198 & 199 into this:

    $wp_customize->add_setting( 'tlg_framework_show_breadcrumbs', array( 'default' => 'yes', 'capability' => 'edit_theme_options', 'type' => 'option', 'sanitize_callback' => 'roneous_sanitize' ));
    $wp_customize->add_control( 'tlg_framework_show_breadcrumbs', array( 'priority' => 5, 'label' => esc_html__( 'Enable Breadcrumbs?', 'roneous' ), 'type' => 'select', 'section' => 'system_section', 'settings'=> 'tlg_framework_show_breadcrumbs', 'choices' => $yesno_options ));

    Step 2. Open up the “helpers.php” file in themes/roneous/inc folder, and change the line 385 into this:

    if ( is_front_page() || is_search() || 'no' == get_option( 'tlg_framework_show_breadcrumbs', 'yes' ) ) return;

    Step 3. Go to Dashboard > Appearance > Customizer > System, and switch the option Enable Breadcrumbs to “No”.

    breadcrumbs

    PS1: You can only see all the options in Customizer panel when the TLG Framwork plugin is activated.
    PS2: In case you don’t want to modify the code, we’ve just released Roneous version 1.0.1 with bugs fixed on Breadcrumbs options which allows you to Turn off Breadcrumbs in Appearance > Customizer > System. Cheers!

    If you still can’t make it work, please send me the admin account of your site via Private reply and I’ll help you out.

    Hope this helps,
    Danny

    #119

    Hi
    It seems I’ve managed to change the link to point to our home page. But I completed only one step from your instructions, because I can’t install TLG now:
    Step 1. Open up the “helpers.php” file in themes/roneous/inc folder.

    How bad is this?

    • This reply was modified 2 years, 11 months ago by  Artem.
    • This reply was modified 2 years, 11 months ago by  Artem.
    #124

    Danny
    Supporter

    Hi Artem,

    The reason is TLG Framework is network activated on your blog, so it isn’t auto detected on multisite yet.
    For the solution, please follow the topic here: http://www.themelogi.com/tickets/topic/missing-options/#post-123

    Thank you.

    #130

    Hello, could you advise how to change some more links:

    The “Our blog” link in the breadcrumbs points to the article which is currently open, but it should point to blog home (http://www.blog.indielocalization.com)…
    Take a look: http://infinit.io/_/Pfj9w2p

    Currently, the “Home” link is pointing to our main domain (http://www.indielocalization.com), I have changed it as you explained.

    Also similarly, the logo (http://infinit.io/_/UBggTm8) should point to our home on the main domain http://www.indielocalization.com

    Could you provide code snippets, please?
    Artem

    #131

    Also, could you help with this too:
    After I changed to HTTPS, icons in the header went missing: http://infinit.io/_/Rr3MCUe

    Thanks

    #133

    Danny
    Supporter

    Hi Artem,

    Please follow the steps here for there changes:

    1, To change the ‘Our Blog’ link, you can open up the helpers.php file in themes/roneous/inc folder, and change the line 417 into this:

    $breadcrumb .= '<li><a href="http://www.blog.indielocalization.com">' . esc_html( get_option( 'blog_title', esc_html__( 'Our Blog', 'roneous' ) ) ) . '</a></li><li class="active">' . esc_html( get_the_title( $post->ID ) ) . '</li>';

    2, To change the ‘Logo’ link, you can open up the layout-standard.php file in themes/roneous/templates/header folder, and change the link in around line 6 into this:

    <a href="http://www.indielocalization.com">
        ...
    </a>

    ( You will need to change logo link in the other header layout files also. For ex: layout-standard-no-top.php, layout-transparent.php,… )

    3, About Icon font, I have just checked your site in https, but it seems to work fine as the screenshot below. Did you fixed it?

    https

    Hope you get this solved, please get back to us if you should need any assistance.
    Danny

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Change Home link’ is closed to new replies.